APAC Invest Login Issue
Incident Report for
CMC Markets
Resolved
This incident has been resolved.
Posted
Jan
27
,
2026
-
22:52
UTC
Investigating
We are currently investigating this issue.
Posted
Jan
27
,
2026
-
22:35
UTC
This incident affected: CMC Invest Australia (Web Platform) and CMC Invest Singapore (Web Platform).
×
Subscribe to Incident
Subscribe to updates for
APAC Invest Login Issue
via . You'll receive .