Incorrect Market Hours - Indices and Commodities
Incident Report for
CMC Markets
Resolved
This incident has been resolved.
Posted
May
27
,
2026
-
00:16
UTC
Update
We are continuing to work on a fix for this issue.
Posted
May
25
,
2026
-
00:24
UTC
Identified
Some markets currently displaying as 'CLOSED' in Product Overview. Pricing and Trading is unaffected.
Posted
May
25
,
2026
-
00:23
UTC
This incident affected: CMC CFD Global (Web Platform, Mobile Platform).
×
Subscribe to Incident
Subscribe to updates for
Incorrect Market Hours - Indices and Commodities
via . You'll receive .